Skip to content

Upcoming compatibility requirements for GitHub Copilot for Eclipse 0.23.0 #492

Open

Description

@jdneo

Upcoming compatibility requirements for GitHub Copilot for Eclipse 0.23.0

Upcoming compatibility change

Starting with GitHub Copilot for Eclipse 0.23.0, the minimum supported environment will be:

  • Eclipse IDE 2025-12 (4.38) or later
  • Java 21 or later to run Eclipse

This Java requirement applies to the runtime that launches Eclipse. Your projects’ Java versions and compiler settings do not need to change.

What this means for you

Version 0.22.x retains compatibility with existing environments, including TM Terminal support. If your Eclipse installation or its Java runtime is below the upcoming minimum, Copilot will show a startup reminder in 0.22.x.

Before upgrading to 0.23.0, update Eclipse and the Java runtime used to launch it.

If you cannot upgrade your environment, you can continue using the last compatible 0.22.x release. Its GithubCopilotForEclipse.zip installation archive will be available from GitHub Releases once published. Install it via Help > Install New Software... > Add... > Archive.... There will not be a separate online update site for the legacy version.

This issue is an advance notice of the planned change. See PR #482 for the announcement implementation.

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions