Repository navigation
Drop python3.10 support for security reasons - #87
Conversation
|
why do we even need pillow? isnt that for pictures |
There was a problem hiding this comment.
Copilot was unable to review this pull request because the user who requested the review has insufficient remaining quota.
An organization owner can choose the repository organization as the billing source for reviews requested by members with a paid Copilot license. Learn about Copilot code review billing.
Vllm, torchvision and mistral-common have it as a dependency. |
timo282
left a comment
There was a problem hiding this comment.
Wenn wir gerade dabei sind: warum haben wir Python <= 3.13?
finitearth
left a comment
There was a problem hiding this comment.
security relevant and 3.10 is close to end of life anyways --> i approve
Wir haben sogar strikt kleiner 3.13. Commit history sagt, dass das wegen vllm mal nötig war. Mittlerweile supported vllm aber Python 3.13. und 3.14. Wegen torchvision muss man aber for some reason Python 3.14.1 explizit ausschließen wenn wir 3.14 mit reinnehmen wollen. Soll ich das so machen? |
Von meiner Seite her gerne, wäre unnötig sich da einzuschränken |
Summary
Raises the minimum Python version from 3.10 to 3.11 so that dependency resolution can pick Pillow 13.0.0, which fixes the open Pillow Dependabot alerts.
Changes
pyproject.toml:python = ">=3.11,<3.13"README.md: Python version badge updated to ≥3.11