When a rbd image is mapped as a LUN, the tcmu-runner will hold the image's exclusive-lock.
If we create a snapshot of this image, it will fail with errno 30 (EROFS: Read-only file system)
Is there any plan or suggestion on how to support rbd snapshot without unbind the LUN, for a reseaon that we may running a VM on this LUN. VM be stopped or crashed is unacceptable when creating snapshot.
#70 is releated to this issue.
When a rbd image is mapped as a LUN, the tcmu-runner will hold the image's exclusive-lock.
If we create a snapshot of this image, it will fail with errno 30 (EROFS: Read-only file system)
Is there any plan or suggestion on how to support rbd snapshot without unbind the LUN, for a reseaon that we may running a VM on this LUN. VM be stopped or crashed is unacceptable when creating snapshot.
#70 is releated to this issue.