Skip to content

ADS-B server with non-standard port fails due to URL encoding #1

Description

@Rubinsergei

If I specify a server with a non-standard port in the config file using the colon : syntax (e.g. 10.9.15.7:8087), the code later URL-encodes this value into 10.9.15.7%3A8087, which causes issues in downstream requests.

For example, the following is generated
https://10.9.15.7%3A8087/data/aircraft.json
which is interpreted as:

host='10.9.15.7%3A8087', port=443
and fails with a NameResolutionError.

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions