From 39b27eefb550c5bddbb2abc1069864d632a67569 Mon Sep 17 00:00:00 2001 From: "dependabot[bot]" <49699333+dependabot[bot]@users.noreply.github.com> Date: Sat, 27 Jun 2026 18:49:01 +0000 Subject: [PATCH] build(deps): update openai requirement from <3,>=1.50.0 to >=2.44.0,<3 Updates the requirements on [openai](https://github.com/openai/openai-python) to permit the latest version. - [Release notes](https://github.com/openai/openai-python/releases) - [Changelog](https://github.com/openai/openai-python/blob/main/CHANGELOG.md) - [Commits](https://github.com/openai/openai-python/compare/v1.50.0...v2.44.0) --- updated-dependencies: - dependency-name: openai dependency-version: 2.44.0 dependency-type: direct:production ... Signed-off-by: dependabot[bot] --- pyproject.toml | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/pyproject.toml b/pyproject.toml index 1f25426..bd8664a 100644 --- a/pyproject.toml +++ b/pyproject.toml @@ -10,7 +10,7 @@ readme = "README.md" requires-python = ">=3.10" dependencies = [ "crewai>=0.86.0,<2", - "openai>=1.50.0,<3", + "openai>=2.44.0,<3", "pydantic>=2.0.0,<3", "pydantic-settings>=2.0.0,<3", "python-dotenv>=1.0.0,<2",